1. ホーム
  2. 製品一覧
  3. ダウンロード
  4. PDFlib 10 ダウンロード
Product

PDFlib / PDFlib+PDI / PPS 10 のダウンロード

PDFlib 10 ファミリの最新メジャーバージョンである PDFlib 10.0.0 がリリースされました。(2022/1)

過去のバージョンからの移行について

過去のバージョンからの移行については、PDFlib Migration Guide(英文)をご覧ください。

PDFlib / PDFlib+PDI / PPS ダウンロード

PDFlib, PDFlib+PDI, PPS は同一のバイナリファイルで提供されており、設定するライセンスキーによりご購入の製品機能を判別します。

ダウンロード後展開したファイル内の bind/言語バインディング/readme.txt を参照し、使用しようとしている言語(およびバージョン)に PDFlib が対応しているかを事前に確認してください。

OS 言語バインディング
winWindows
Windows Server x86
Windows 8/10/11 x86
C, C++, Java, Perl, PHP (*1), Python, Ruby
Windows Server x64
Windows 8/10/11 x64
C, C++, Java, Perl, PHP (*1), Python, Ruby
macmacOS
macOS (10.9以降) x64/arm64 C, C++, Objective-C, Java, Perl, PHP (*1), Python, Ruby
.NET Universal
Windows x64, Linux x64, Alpine Linux x64, macOS x64 .NET がサポートするすべての
言語バインディング
linuxLinux / Alpine Linux
Linux x86 (32-bit) C, C++, Java, Perl, PHP (*1), Python, Ruby
Linux x64 C, C++, Java, Perl, PHP (*1), Python, Ruby
Alpine Linux x64 with musl C C, C++, Java, Perl, PHP (*1), Python, Ruby
Linux ARM64 (aarch64) C, C++, Java, Perl, PHP (*1), Python, Ruby
Linux IBM zSeries 下記参照
FreeBSD
FreeBSD 12 x64 C, C++, Java, Perl, PHP (*1), Python, Ruby
IBM AIX
IBM AIX 7.1 以上 64-bit C, C++, Java, Python
Mobile / Embedded System
iOS 64-bit Objective-C, C, C++
Android 32-bit / 64-bit Java
組み込み Linux 向けの PDFlib Mini Edition ついては こちらからお問い合わせください
IBM System i and System z
IBM System i 7.2 以上 (64-bit) C, C++, RPG, Java (*2)
IBM System z (USS, 64-bit) C, C++ Java
IBM System z (MVS) C (*3)
Linux-S390x (64-bit) C, C++ Java

(*1) PHP の詳しい説明は PDFlib in PHP HowTo をご参照ください。特に、OS X 上での PHP 版 PDFlib の使用について、特記事項があります。
(*2) System i 向けの Java バインディングには AIX 向けのバイナリをお使いいただけます。詳細は「Deploying AIX Binaries on IBM i5/iSeries with PASE」(英語)をご覧ください。
(*3) 近日中にリリース予定

各言語の対応バージョンは以下の通りです (プラットフォームによって対応バージョンが異なる場合があります)。

  • PHP 7.4、8.0、8.1
  • Perl 5.28, 5.30, 5.32, 5.34
  • Python 3.3 以上
  • Ruby 2.6, 2.7, 3.0

Windows などにおいて、OS が 64 ビット版であっても、PDFlib を呼び出す開発言語プラットフォームやアプリケーションサーバが 32 ビットモードで実行されている場合、32 ビット版を使用してください。

正しくダウンロードできていることを確認できるよう MD5 checksums を公開しています。

PDFlib マニュアル(日本語版)

マニュアル(日本語版)へのリンク 説明
japan PDFlib 10.0.0 チュートリアル PDFlib / PDFlib+PDI / PPS 10.0.0 チュートリアルの日本語版です。
japan PDFlib 10.0.0 API リファレンス PDFlib / PDFlib+PDI / PPS 10.0.0 API リファレンス の日本語版です。
japan pCOS パスリファレンス PDFlib+PDI / PPS 10 の pCOS インターフェース 13 の pCOS パスリファレンスの日本語版です。

PDFlib マニュアル(英語版)

マニュアル(英語版)へのリンク 説明
PDFlib 10.0.0 チュートリアル PDFlib / PDFlib+PDI / PPS 10.0.0 チュートリアルの英語版です。
PDFlib 10.0.0 API リファレンス PDFlib / PDFlib+PDI / PPS 10.0.0 API リファレンスの英語版です。
pCOS パスリファレンス PDFlib+PDI / PPS 10 の pCOS インターフェース 13 の pCOS パスリファレンスの英語版です。
PDFlib in PHP HowTo PDFlib を PHP で使用するための HowTo です。

Block Plugin 6 (PPS 10 に対応)

OS ファイル
icon Windows
Acrobat X/XI 32-bit
Acrobat Pro DC (32-bit)
BlockPlugin 6.0
icon Windows
Acrobat DC 64-bit 用
BlockPlugin 6.0
icon macOS
Acrobat Standard and Pro 2017/2020 (Intel)
Acrobat DC (universal binary for intel and M1)
BlockPlugin 6.0

PDFlib BlockPlugin は、PDFlib Personalization Server(PPS) 10.0.0 以降のバージョンに対応しています。

新しいバージョンのBlockPluginをインストールする前には、旧バージョンをアンインストールする必要があります。ご注意下さい。

Block Pluginは、以下のAcrobatのバージョンで動作します。

  • Windows:
    • Acrobat X/XI
    • Acrobat Standard and Pro 2017/2020
    • Acrobat Pro DC (32-bit/64-bit)
  • mac:
    • Acrobat X/XI/DC Professional on macOS

このプラグインは、Adobe Reader/Acrobat Readerでは動作しません。

PDFlib Block Plugin マニュアル

マニュアルへのリンク 説明
How to install the PDFlib Block Plugin PDFlib Block Plugin 6.0 の英語版インストールマニュアルです。
japanPDFlib BlockPlugin マニュアル PDFlib Block Plugin の日本語版マニュアルです。
System Requirements for PDFlib Block Plugin PDFlib Block Plugin のシステム動作要件をまとめたドキュメントです。